Author Topic: Mesh scale solution  (Read 4964 times)

zeroChaos

  • Newbie
  • *
  • Posts: 5
    • View Profile
Mesh scale solution
« on: December 07, 2009, 09:53:36 PM »
     Hello there. At firt I would like do congratulate you for this amazing piece of work. Really awersome.
I tested it and found it very useful, but I also had a little problem related to the mesh scales. It seems that 3ds max's default scale is far bigger than meshmixer's one, so I can't even see meshes modeled in Max inside meshmixer.

     Maybe you could figure out some way to adjust the meshes scales, because it seems to be a very common thing, diferent having different scales.
Anyway, it's already an wonderful tool, thanks for releasing it for free ;). Keep up the good work, cheers.

Fonte Boa

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Mesh scale solution
« Reply #1 on: December 08, 2009, 06:23:17 AM »
<<It seems that 3ds max's default scale is far bigger than meshmixer's one, so I can't even see meshes modeled in Max inside meshmixer.>>

zeroChaos,
you can solve this easily by setting a greater value at "Object Scale" field in
3dsmax File | Import | OBJ Import Options dialog, at "geometry" field:
for example, "12".
:)

RMS

  • meshmixer founder
  • Administrator
  • Hero Member
  • *****
  • Posts: 1238
    • View Profile
    • gradientspace
Re: Mesh scale solution
« Reply #2 on: December 08, 2009, 12:03:29 PM »
I do zoom the camera to relative scales, but perhaps the clipping planes are broken. Can you send me an example file?
cheers,
-RMS
created meshmixer - now starting gradientspace - meshmixer consulting available http://www.gradientspace.com/consulting

zeroChaos

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Mesh scale solution
« Reply #3 on: December 08, 2009, 02:10:05 PM »
Fonte Boa, thanks for the tip. As I had never had to worry much about scale before, I hadn't noticed that. It solves the problem, but requires to put a smaller value when exporting and a bigger one when importing back combined meshes to max. Anyways, it solves my problem and I'm really grateful for that :).

RMS, I made these two cylynders quickily in max and exported both to obj, one with the obj scale setting set to 0.5 and the other on to 1.0 (default value).
Hope you find it useful for solving any problem, and thanks again for shuch an amazing tool ;D