Author Topic: Problems installing Meshmixer 2.9 on Xenial 16.04  (Read 4407 times)

ayourk

  • Newbie
  • *
  • Posts: 1
    • View Profile
Problems installing Meshmixer 2.9 on Xenial 16.04
« on: May 02, 2016, 05:45:26 PM »
I recently upgraded my Ubuntu system from Trusty to Xenial.  Once I did that, several dependencies for this package went away.  I have since fixed this by having those packages from Trusty rebuilt for Xenial and put them up on my Launchpad.net PPA archive:  ppa:ayourk/xenial

If there are other packaged dependencies that are missing, please let me know, and I'll add them to the PPA.

pmjboyle

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #1 on: July 06, 2016, 03:39:31 PM »
Hi,

Thanks so much for posting this. I did add your ppa then I tried using dpkg to install the meshmixer .deb; the errors related to superlu and blas were resolved, but some of the boost dependences as well as cgal10 and kml0 were not. See below.

Warm regards,
Patrick

--

00:19:19 > sudo dpkg -i ~/Downloads/meshmixer_2.9_amd64.deb
Selecting previously unselected package meshmixer.
(Reading database ... 408873 files and directories currently installed.)
Preparing to unpack .../meshmixer_2.9_amd64.deb ...
Unpacking meshmixer (2.9) ...
dpkg: dependency problems prevent configuration of meshmixer:
 meshmixer depends on libavahi-compat-libdnssd1 (>= 0.6.16); however:
  Package libavahi-compat-libdnssd1 is not installed.
 meshmixer depends on libboost-date-time1.54.0; however:
  Package libboost-date-time1.54.0:amd64 is not installed.
 meshmixer depends on libboost-filesystem1.54.0; however:
  Package libboost-filesystem1.54.0 is not installed.
 meshmixer depends on libboost-system1.54.0; however:
  Package libboost-system1.54.0:amd64 is not installed.
 meshmixer depends on libboost-thread1.54.0; however:
  Package libboost-thread1.54.0 is not installed.
 meshmixer depends on libcgal10; however:
  Package libcgal10 is not installed.
 meshmixer depends on libkml0; however:
  Package libkml0 is not installed.
 meshmixer depends on libsuperlu3 (>= 3.0+20070106); however:
  Package libsuperlu3 is not installed.


dpkg: error processing package meshmixer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Errors were encountered while processing:
 meshmixer
pmjboyle@shipandanchor : /home/pmjboyle ------------------------------------------------------------------ 15:34:32
00:19:34 > sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libavahi-compat-libdnssd1 libblas3gf libsuperlu3
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libavahi-compat-libdnssd1 libblas3gf libsuperlu3
The following packages will be REMOVED:
  meshmixer
The following NEW packages will be installed:
  libavahi-compat-libdnssd1 libblas3gf libsuperlu3
0 upgraded, 3 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/171 kB of archives.
After this operation, 167 MB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 409396 files and directories currently installed.)
Removing meshmixer (2.9) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Selecting previously unselected package libavahi-compat-libdnssd1:amd64.
(Reading database ... 408873 files and directories currently installed.)
Preparing to unpack .../libavahi-compat-libdnssd1_0.6.32~rc+dfsg-1ubuntu2_amd64.deb ...
Unpacking libavahi-compat-libdnssd1:amd64 (0.6.32~rc+dfsg-1ubuntu2) ...
Selecting previously unselected package libblas3gf.
Preparing to unpack .../libblas3gf_1.2.20110419-10_all.deb ...
Unpacking libblas3gf (1.2.20110419-10) ...
Selecting previously unselected package libsuperlu3.
Preparing to unpack .../libsuperlu3_3.0+20070106-3_amd64.deb ...
Unpacking libsuperlu3 (3.0+20070106-3) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Setting up libavahi-compat-libdnssd1:amd64 (0.6.32~rc+dfsg-1ubuntu2) ...
Setting up libblas3gf (1.2.20110419-10) ...
Setting up libsuperlu3 (3.0+20070106-3) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...

dnkrtz

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #2 on: July 30, 2016, 02:19:56 PM »
Bump!

I get this same error. Any fix in sight?

Thanks,
Aidan

frankv

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #3 on: September 09, 2016, 03:36:48 AM »
Me too... bump.

Toolsmith

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #4 on: September 23, 2016, 06:13:21 PM »
Just installed today, same issue...bump.  This was a clean installation of Meshmixer on a new 16.04 installation, so no libraries from any previous version are available.

It's been over 2 months since this was reported with no reply from the Powers that Be.
« Last Edit: September 23, 2016, 06:15:57 PM by Toolsmith »

SamwiseFilmore

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #5 on: October 17, 2016, 11:16:07 PM »
Any way to bug "The Powers that Be" into paying us a little attention?

doctek

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #6 on: October 21, 2016, 10:02:25 PM »
One quickly gets the feeling that "the powers that be" give a chubby rodent's rump about Linux and making Meshmixer work with it!
Really too bad. Guess I'll stick with Mesh Lab.

MagWeb

  • Administrator
  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
I'm just a user as you are. Being no Autodesk employee: I do not know where this road will lead to, nor do I claim to've all stuff got right.

ataraxus

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #8 on: October 25, 2016, 05:17:45 PM »
Hello Folks,

i also couldn't get meshmixer running with this ppa..
Nevertheless i create a platform independent solution based on docker: https://github.com/ataraxus/meshdoxer
this definetely works with ubuntu 16.04 but should also work with any ubuntu version with docker support. probably also with other distros, but i'm not sure, since it needs to mount x11 into th container.

If you can use this and it works for you please let me know on github! I wont check this site often and i'm struggling with the captchas apparently i'm a bot  :-\

cheers!

PS: hopefully meshmixer will be provided as a flatpack or snap image eventually. this should boil down the support effort equally to win/mac

cappy0815

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #9 on: November 28, 2016, 11:17:27 AM »
Hey guys,

@ataraxus: meshdoxer won't work on my system.
I did everything like you described on github.

something like libboost is missing. same message as on installing meshmixer directky.

Cappy

Kessler

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problems installing Meshmixer 2.9 on Xenial 16.04
« Reply #10 on: July 25, 2017, 12:58:41 PM »
Hey guys,

@ataraxus: meshdoxer won't work on my system.
I did everything like you described on github.

something like libboost is missing. same message as on installing meshmixer directky.

Cappy

Hey Cappy, did you get it working in the end?